Back to overview
Degraded

General connection- and timeout issues (fix live: monitoring the situation)

Nov 24 at 11:18pm CET
Affected services
Website & panel
AutoPrint service
Staggered Start service

Resolved
Dec 10 at 01:00am CET

After a hectic week we now feel confident resolving the degraded status of SimplyPrint, all major functionality should now be restored including AI and other miscellaneous issues. There will still be slight differences in functionality and expected behavior, do not hesitate to reach out in our Live Chat (https://simplyprint.io) or via discord (https://simplyprint.io/discord) so we can get it fixed, and you back up and running again :)

Thank you very much for your ongoing patience and support, we will continuously be monitoring and improving our capabilities over the next couple of weeks in the background.

Updated
Dec 04 at 01:30am CET

We are still monitoring the situation and deploy various daily smaller patches for small bugs. Just deployed:

Bug Fixes
- Improve & fix AutoPrint, Staggered Start and normal print sending reliability in some cases
- Re-added "Clear Timeout" to AutoPrint
- Fix webcam in app (does not require any updates)
- Handle errors more gracefully in gcode preview
- Various small slicer improvements that accumulated to faster slicer startup

Known issues left to fix:
- AI updates not showing in timeline preview
- Mesh data visualization not showing up
- CPU information not appearing in device widget
- Goto OctoPrint/Klipper button
- OctoPrint macro syncing

Estimated full fix and back to normal; 1-2 days.

Updated
Dec 03 at 01:25am CET

More fixes now live:
- HMS (Bambu Lab notification fixes)
- Print queue now live-updates again, removing items that have just been started, no longer requiring reload

We're still monitoring the situation and will keep this incident report updated.

Updated
Dec 02 at 11:00pm CET

Various fixes now live:
- Multi Material Sync (Bambu Lab AMS sync) works again
- AutoPrint issues fixed
- Webcam issues and a few "Failed to start print", where print did start fixed

Still being addressed:
- Bambu Lab HMS notifications improved, but not fully fixed: full fix live within a couple of hours

Lastly, we have received one report of webhooks not being received: this is unconfirmed and not reproducible on our end, and our logs show that webhooks are (and for the one customer, were) sent and received, but do reach out to our support if you experience any webhook-related issues.

Updated
Dec 02 at 01:30pm CET

The fix has been live for about 16 hours and is confirmed to work across the board.

This update, however, was a "2 steps forward, 1 step back" situation, and - as we were aware might've been the case - fixing the big thing at the speed that we did, some smaller things could potentially break.

Today, there have been reports of the following bugs:
- Multi Material Sync not working (Bambu Lab AMS sync)
- AutoPrint being paused for longer periods
- Bambu Lab "HMS" notifications not being reported and not being clearable
- A few problems with webcams (fleeting)

We are working on addressing all of these.

Updated
Dec 01 at 09:25pm CET

An update addressing the connection and timeout issues has been deployed, and the fix has been confirmed to work across all of SimplyPrint.

The fix took over a week and includes major upgrades in our local infrastructure.

We apologize for the inconvenience caused by this - we were, unfortunately, taken by surprise by these issues that were rooted in growing pains from a sudden unexpected surge in activity and new signups, that we should - and now will - have been better prepared for.

A blog post detailing what happened, what we've changed and what we have been, and are, doing to make sure something like this doesn't happen again will go live within a couple of days, and all affected customers whose production or trial periods were affected can message us to get extended subscription time or reset trial periods.

Created
Nov 24 at 11:18pm CET

Starting the week of November 24th, some SimplyPrint users have been experiencing connection issues and print-start issues, with print starts timing out and live printer data being unavailable. Since then, a fix has been applied that fixes the connection and timeout issues (on Dec 1st). We're still monitoring the situation.